Talk:Victory or Death

From Guild Wars 2 Wiki
Jump to: navigation, search

Not Doable?[edit]

This one appears to be undoable - at least not by a single player. Risen Sentinels and Risen Berserkers stopped me cold at the very first objective of retreiving power cores for the air ship. There is exactly zero legitimate information on how to complete this dungeon on this Wiki. The largest problem with gaining the power cores is that the Sentinels and Berserkers are very near invulnerable, taking enough time to kill each one that they respawn in endless supply. After spending a bit over 2 hours grinding at this, killing 30 of these juggernauts, and having the exact same number to deal with as when I started, I gave up in disgust and left the area. My advice, don't even bother trying unless you have a very LARGE and STRONG party of players to join up with. As this is a Dungeon and not a mission scenario as with every other one in the personal story line, it appears that the game designers specificvally did this to ensure that solo players will never be able to complete the story line. Ecks

Er, well... yes. Felix Omni Signature.png 03:31, 17 October 2012 (UTC)
Dungeons are not solo content. Victory or death, unite or perish. That's the theme carried by the last chapters (60+) of personal storyline. Mediggo 06:35, 17 October 2012 (UTC)
I agree with Eck, it's not doable solo, even though that was the cantra before release. As to the unite or perish. That's the theme carried by the last chapters (60+) of personal storyline. idea, I've solo'd everything in my personal story. A bit wierd that they'd force a party only quest (dungeon) into our personal story. --Enda - talk 00:46, 21 October 2012 (UTC)
Yeah, everything in the personal story is solo-able up until this. But hey, you want to kill a dragon, you're gonna need some friends. It's not hard to get a party.
That was part of the charm of the first Guild Wars, though: that you *could* complete the entire game's storyline without grouping with other people. And in this game, given that *every* other story quest gives *no* rewards to the person helping you aside from whatever loot/experience they get from killing mobs, it seems odd that they'd all of a sudden change it for the final mission. 96.227.7.212 00:07, 30 October 2012 (UTC)
Once upon a time, helpers could get some karma for participating in personal story missions, but Anet seems to have thought that was not fair or something. Whether it "makes sense" for the last mission of the personal story to be in a dungeon is debatable; I think that the bigger problem is the sense of missing rewards for people who are not satisfied with Anet's decision (can't/won't do it with a party, refuse to do dungeons, never online when Arah is open, whatever the case). The Pact weapons don't matter since they are not even exotics and most of them aren't soulbound, so you can just buy them off someone else who doesn't want theirs. However, it's the end of the personal story, and even though it's fairly blah overall, leaving a story/quest unfinished forever is really annoying if you've bothered to slog through it to this point. It's just anticlimatic, even for people that aren't obsessive completionists. Finally, the +1000 influence is a major asset - the amount of time or effort it would take to gain that otherwise is pretty high, and it's especially great since you can choose what guild to spend it on. That is a big reward to pass up, so I can understand why people would be upset. Vili 点 User talk:Vili 00:27, 30 October 2012 (UTC)
I finally made it to this part of the story (after having a crap time just getting there, frankly) and was incredibly frustrated to discover this. I'm not opposed to playing with others, I just prefer to solo. I don't think I would have been as frustrated/annoyed right now if the story hadn't been SO easy to breeze through solo . . . until now. If there had been some sort of indication that the ending would be this difficult, I could have been prepared. But as it stands now, it just feels like this long build up only to run head first into a brick wall. I don't think that part of it is fair at all. 72.181.139.204 01:59, 21 May 2014 (UTC)bluesabriel
The new problem emerging is that there are fewer characters wanting/needing to complete this story. The real test is not the dungeon but raising a party. Maybe it should be renamed Long Wait or Give Up though I admit that loses something atmospheric . . . (Allt Banon 10:04, 8 December 2012 (UTC))
It's not even physically doable with less than two players, because that's the minimum needed to open one of the doors right at the start. And in practice I suspect it's not physically possible to do that bit without at least three, no matter how uber everyone is, because *someone* needs to keep the (endlessly respawning) defending mobs well away from the two players trying to open it, for long enough for them to finish doing so (and the mobs have a pull attack that will disrupt the opening if they get too close - although I guess it's possible that stability might help there). I know that I and a couple of friends spent a good hour or more trying to get past that point, and never managed to get the door past about half open. As to what then follows - never having got that far, I have no idea.--Doghouse13 (talk) 22:46, 6 January 2014 (UTC)
Of course it is physically doable. You'll be asked at the gate if you want to enter the dungeon or your personal Story. Entering is not a problem. The Dungeon itself is. I tried it ten times solo, it is not possible. Elite Risen Enitites, at least two at a time, plus 3 "normal" Risen. You'll get four NPC's to help, but they are mostly useless. I am stumped. This is really annoying, I don't think I can find another two or three lvl 80 guys to help me out with that. This game has just become unfinishable :( 95.91.225.211 09:12, 19 March 2014 (UTC)
try using the LFG tool in game make a posting most of the time they fill up quick.(more so if you do it during peak times)-User Zesbeer sig.png Zesbeer 09:17, 19 March 2014 (UTC)
I used the LFG tool to assemble a complete pug party only a week or so ago, so there are definitely people who still do it. Also, two players could open the door by utilizing stealth and/or playing super tanky builds. One of my former guildies "soloed" the rest of the dungeon after getting a random dude to help him open the door. The rest of the boss fights etc are actually pretty easy; opening the door is probably the most challenging part of the whole dungeon. Vili 点 User talk:Vili 02:54, 21 May 2014 (UTC)

Is Arah event bugged?[edit]

I have been waiting to get into Arah for 3 days now. Everyone is saying its bugged but I want to confirm this. This is the 4th bug that has prevented me from moving through story mode. In fact this is the buggiest game I have ever played. Even worse than Champions online! YIKES!The preceding unsigned comment was added by 24.98.21.176 (talkcontribs).

few things this is not the place to ask about bugs, ask about bugs on the official forums. Second please sign your comments by typing four tildes (~~~~). Lastly please submit a bug ticket if the event chain is bugged.- User Zesbeer sig.png Zesbeer 22:20, 12 November 2012 (UTC)

Connection between this mission and the dungeon?[edit]

I don't understand the connection between the "Victory or Death" personal story chapter and The Ruined City of Arah (story) dungeon. If I complete this personal story chapter, do I get credit for having done the dungeon? If I have done all previous story chapters and I do the dungeon, does that count as having completed "Victory or Death"? Or will I have to complete the same dungeon twice? - 192.195.66.3 16:11, 13 February 2013 (UTC)

The Victory or Death step in the personal storyline requires you to finish the story mode of Arah. If you finish the dungeon before you are on the step where you actually have to Kill Zhaitan in Arah(story) you will have to do the storymode again. Magistrella 16:17, 13 February 2013 (UTC)

End mission question[edit]

I haven't played this game in a while. I had my characters up to the end of the game (victory or death) but could never get in to the dungeon because it required having other quests done at the same time, but that required other people to complete those quests to open the door so my group could go into the dungeon... is this still true or did they (the programmers) change the end of the game? Varuuth (talk) 04:02, 14 May 2013 (UTC)

The entrance to Arah dungeon (and the waypoint near it) are always open now, except when the event to overtake the place is occuring. So if you can't use the waypoint, you should participate in the event. :) --Alad (talk) 05:34, 14 May 2013 (UTC)
Sweet! Thank you :-) Varuuth (talk) 13:11, 14 May 2013 (UTC)


How to start the mission?[edit]

Ok this is going to sound dumb. My friend and I get into the same party, then jump to the waypoint in The Narthex. When I talk to the guy by the door to the Ruined City of Arah (can't remember his name), he just has some dialog nothing that actually starts the mission. So I go through the door into the Ruined City of Arah, and it asks if I want to use the LFG tool, or if I want to go into story mode. I hit story mode, and my friend it left standing outside. If he tried story mode, he winds up in a different instance then me. How do we get there together? Not sure if this important or not, but he isn't that far along in his story line. He still has a dozen things left in his story line before he gets to Victory or Death. Any tips? Thoughts? Varuuth (talk) 02:02, 22 October 2013 (UTC)

are you both on the same server?-User Zesbeer sig.png Zesbeer 02:46, 22 October 2013 (UTC)
good question, but yeah when we are standing outside of the door we can see each other. Varuuth (talk) 13:17, 22 October 2013 (UTC)
well if he is guesting or you are guesting and one of you is from eu and the other na then you wont be able to play together in dungeons.-User Zesbeer sig.png Zesbeer 20:24, 22 October 2013 (UTC)
Nope both playing on the same server. Both accounts created on the same server. and both accounts created within a few hours of each other back when the game was released. Varuuth (talk) 22:21, 22 October 2013 (UTC)
update to my last post, we tried again last night and it worked for some reason. Now I just have to find 3 mores people to run with. Can't do it with just 2. Lol Varuuth (talk) 17:32, 26 October 2013 (UTC)

Fixed bug[edit]

The bug causing Beigarth/Izu and Gara/Shashoo to have the same dialogue has been fixed.--173.180.63.220 19:02, 24 October 2014 (UTC)

Story Journal Bug[edit]

I completed the story back in 2013, and instead of giving the entry for this mission, it just added the journal entry for "Temple of the Forgotten God" again. Has anyone else seen this bug?

Probably due to the recent "redo" of personal story -- Crazy (talk) 17:38, 29 July 2015 (UTC)


Story Dungeon Bug[edit]

2 days ago, two friends duo'ed the Story dungeon and it worked. Today, I'm trying to solo it and it buggs at "Keep watch for Orrian forces as the airship advances". First try : the cannons are not usable (they have a green star over them and have a green outline but no matter where I place my character, I cannot interact with them). Second try : I had to afk for 1 mn when I popped on the airship, so it started moving without me interacting. Then i'm surrounded by giants who do nothing + the cannons dont even look usable. -- Crazy (talk) 18:13, 29 July 2015 (UTC)

Aaaaand tried a third time with another person and still have the cannon bug :( -- Crazy (talk) 18:41, 29 July 2015 (UTC)
I am also currently having the cannon bug. :( --Spigs 15:36, 31 July 2015 (UTC)
This appears to be a bug introduced in the patch that broke everything.
Can confirm. Cannons are unusable. Giants are successfully attacking. It seems that ALL instances of usable objects has ceased. Even the repair station does not work. I reccomend submitting trouble tickets whenever you get a chance. At some point, ANet will HAVE to respond to it if enough people flood their help desk with tickets. Problems can only be ignored for so long. And at some point someone will get tired of deleting all the help tickets. User FelixCarter Sig.png FelixCarter 20:25, 31 July 2015 (UTC)
Technically, not *all* usable objects are unusable : before I got on the plane, I was able to use the anvil inside the dungeon - bot not the one on the plane though -- Crazy (talk) 11:04, 2 August 2015 (UTC)
I think the thing that bothers me most is that this is LITERALLY preventing people from completing the game. I couldn't imagine being a first-timer being confronted with this and not realizing it's a bug. And even if they do realize it's a bug, that's gotta be a crappy feeling. Also, considering how many people are already upset with the story ending as it is in general, this bug is really just all that more embarrassing. :/ --Spigs 04:24, 2 August 2015 (UTC)
I am a new player to both MMOs and GW2. First choice for me? Human Ranger and it ends with this bugged quest. Now I don't really feel motivated to do anything. It's like a paying for a movie ticket and the theater catches on fire during the last 20 minutes of the film. I feel cheated now. --T3chno1983 (talk) 06:43, 7 August 2015 (UTC)

Edited the title, as it seems it's not a solo bug but a general bug -- Crazy (talk) 11:06, 2 August 2015 (UTC)

Yes, it's not a solo bug because I tried duo the Personal Story today and it didn't work. Sent in ticket problem today. Hopefully, there will be a next patch update to fix the bug. --Fairyzaru (talk) 14:23, 2 August 2015 (UTC)
I don't get it ... so I somehow managed to do the whole mission on the 27th, without bugs, and document everything I could, but everyone else gets shafted by a cannon bug? I guess it was Game updates/2015-07-28 that did it then. Bad luck. -Chieftain AlexUser Chieftain Alex sig.png 23:19, 4 August 2015 (UTC)
Forum threads: "Victory or Death" Bug + Please Post 7/28 Bug Reports HERE. I'm gonna stick a big old notice at the top of the article advising players not to bother. -Chieftain AlexUser Chieftain Alex sig.png 23:26, 4 August 2015 (UTC)
Thanx -- Crazy (talk) 11:37, 10 August 2015 (UTC)
As of today [1] it's supposed to be fixed, but some ppl on the forum thread [2] say they still are bugged (not all though) -- Crazy (talk) 21:28, 11 August 2015 (UTC)

Story dungeon now doable but still some issues[edit]

Tested with the same 'bugged' character (see above) and it worked! Thought there might still be a bug : Destiny's Edge is helping you before you board the airship and when you board the last airship, but not in between. Therefore, some of the fight are tough, especially solo -- Crazy (talk) 12:14, 12 August 2015 (UTC)

Relatively difficult, yes. This is however exactly the behavior that I noted in the walkthrough the other day (see the brackets marked "solo" and "aided by Destiny's Edge"). Probably not a bug but the intended behavior I expect. -Chieftain AlexUser Chieftain Alex sig.png 13:09, 12 August 2015 (UTC)
Redid it today with a MM Necro, and it's easier if you've got pets to keep aggro away from you while you use cannons -- Crazy (talk) 12:40, 14 August 2015 (UTC)

Another (smaller) bug : at the very last fight, vs Zhaitan itself, I managed to get stuck "in the air" (at least that was the reason I was given when I wanted to leave the cannon), and couldn't fire anymore. Probably the consequence of being bumped at a wrong time. It solved itself when I got hit by some knockback attack, which made me forcefully leave the cannon, and I was able to finish then. -- Crazy (talk) 12:40, 14 August 2015 (UTC)

Story dungeon not soloable (08/14/2015)[edit]

Not sure if this is intentional or not, but solo you never get past the giants as the random spawns keep coming when you're ih the turrets trying to kill giants and the deck mobs just overwhelm you. I've tried hopping in/out of the pods but nothing seems to work. (80 sorcerer here, I don't usually have issues but this is a blocker for me.) The preceding unsigned comment was added by 76.104.157.22 (talkcontribs) at 23:40, 14 August 2015‎ (UTC).

It is definitely tough to do. Try swinging by the Players helping Players page and asking for advice. With the update, a lot of other people will be racing to get it done, and learning tricks at the same time. G R E E N E R 00:11, 15 August 2015 (UTC)
It's a bit easier if you've got something to take / tank the agro, as a "sorcerer", I'd suggest earth based Glyph of Lesser Elementals and Glyph of Elementals since they're best at tanking --BramStoker (talk, contribs) 07:51, 17 August 2015 (UTC)

Destiny Edge members are lazy[edit]

Kill Zhaitan, defend the bridge... But what are those guys doing ? Cheerleading ?--193.48.141.104 19:52, 8 November 2015 (UTC)

Well, that sucked. (Solo, not the best move...)[edit]

Level 80 (duh) Human Daredevil (Thief Plus), all-exotic gear. The first parts seemed tough but OK (especially since Caithe will revive you and as far as I can tell, she is indestructible), but...

I get to the landing platform where you must kill the three towers, and it started to get a bit difficult. Oozes, not a big deal, flail away with a staff for group damage, they go down, the tower goes down. Weapons, annoying, but Balthazar doggies helped out with them. Tower down. Gorillas: ugh. Spent a lot of time stunlocked, got killed once, but finished them. Then the Mouth. Bah. I didn't even see him go into Vortex mode so I could throw flame orb things at him.

So I'm with the folks up above who say/said that it's a bit bogus that the last mission of the "Personal" story is in fact a requires-a-group mission. (secondary note: I remember, back at release time(*), two characteristics of personal story missions when you had a fellow player along to help: (1) the helper(s) got Karma points for helping, and (2) like for dynamic events, the difficulty scaled up a bit as the number of participants increased.)

(*) I played during the unofficial three hour early opening of the servers on Early Start Day.

Or maybe it's me who sucks... Cynique (talk) 11:42, 24 June 2016 (UTC)

The mission you were on was originally a five-man dungeon. It's been modified somewhat since release to make it accessible to solo players. Admittedly it could use some more work. G R E E N E R 16:43, 24 June 2016 (UTC)
Sure, I get that it was originally a 5-man dungeon. I just object somewhat to a *personal* story containing a mandatory(*) *group* mission.
(*) Mandatory if you want to finish the personal story, that is... Cynique (talk) 18:40, 24 June 2016 (UTC)
It's doable solo, just difficult. Truth be told, thieves are generally fairly squishy, and those gorillas were a pain even when they were scaled for five folks. And I do believe this mission scales up if you have more folks. Konig 19:21, 24 June 2016 (UTC)

Feedback 2017/02/26[edit]

Bugs are still in effect. Cannons sometimes are not interactive, first airship is immobile, and airships' image glitches in and out. The bugs can not be fixed afterwards, but watching through the entire cutscenes can prevent a stuck instance from occurring. The most important cutscenes are the ones after the third airship part or before boarding aircraft. Not using the Waypoint within the instance may also help. User Foxman525 Image-User Foxman525 sig.png Foxman525 05:30, 27 February 2017 (UTC)

Feedback 2017/11/19[edit]

Human nobles have an additional line with Wozmack before he starts his tricks: https://imgur.com/a/Sy0nl --99.13.227.47 00:37, 26 November 2017 (UTC)

Added what's in those images, but what does the more continue go to? Regular hue change or directly to moas (I'd imagine moas given the context given that he pulled the hue and attacked-by-birds trick in human noble storyline). Konig (talk) 01:46, 26 November 2017 (UTC)
It goes to him talking about hues, the same as choosing 'Magician, eh? Show me something, then. Dazzle me.' 99.13.227.47 03:40, 30 November 2017 (UTC)

No Credits?[edit]

The first time I completed personal story, back in 2015, I remember scrolling credits, before Wozmack appeared. But when my roommate completed personal story last year, no credits ever appeared. (And he was probably using max graphics settings.) When I completed personal story on another character a couple days ago, no scrolling credits appeared for me either. (I was on low graphics settings at first, but tried adjusting them.) Have the credits been removed (not likely) or is there some bug that occasionally prevents them from appearing? —Karob • 14:59, 6 March 2018 (UTC)

That's odd. I can picture what those credits look like as they scroll by; yet much like you, I haven't completed the main story for some time. They're currently mentioned in the trivia section as being present. Perhaps I'll move another character through the story arc to see for myself. G R E E N E R 16:31, 6 March 2018 (UTC)
I did this mission not so long ago and I didn't realised it, but yes, maybe you're right. I can't remember seeing the credits. But maybe you have you just have to wait much longer or they will only show it on your first character?? I waited some times after talking to the characters so that Wozmack the Wonderful appeared (I tried to capture his dialogs and sooner or later I will update the page) and the credits will only show after his tricks. But they did not show up immediately after his final trick. So a) maybe you really have to wait a long time to get them b) they only show up once c) there is really a bug or something preventing the credits to show. Balwin (talk) 18:03, 6 March 2018 (UTC)
Late on this but adding my two cents. I finished it somewhere around middle past year and I can't recall any scrolling credits (I just learned about its existence through this article). I interacted with every interactable NPC in that area, I waited long enough that Wozmack appeared, I played with his tricks, I played with the Boxes o'Fun several times, Fear of This Night played then stopped followed by 3 or 4 songs and I was still there: no scrolling credits at all. It was on my first character (even though I took 4 years to finally finish that story lol). Then, I can confirm that it didn't show up and I can't see if I did something wrong (or missed something) to prevent it from happening. —Txonä Atan - (talk) 11:18, 21 January 2019 (UTC)
I just completed this today on a character I made back in 2012. No end credits during or after song. I was on a Charr Engineer, if that weighs in. The preceding unsigned comment was added by 135.23.32.213 (talk) at 20:02, 24 January 2019 (UTC).