Talk:Command line arguments

From Guild Wars 2 Wiki
Jump to: navigation, search

-perf[edit]

This command line argument works by putting a small box on the right side of the screen with a lot of video information in in. Not so sure Its worth having there. KJZ 08:55, 29 April 2012 (UTC)

On the 3rd BWE (7/22/2012) this command didn't work. Is it disabled completely? --Dovah.5917 16:32, 23 July 2012 (UTC)

I didn't try during the BWE3, but did attempt to use the command during the stress test. Couldn't get it to function at all. I also tried -perfs, since that's the command I used for GW1. On one hand it's not entirely necessary with the FPS shown in the options dialog, but I would still like to have it available for monitoring during regular play (particularly because my machine is underpowered). Nkuvu 18:54, 4 August 2012 (UTC)

-image[edit]

With one of the latest updates to the Beta client, this no longer appears to be working. Instead of pulling up a simplified window and automatically closing after the program is done, it now opens as if the command line argument wasn't there. Am I the only one with this issue? Initia Nova 21:08, 5 June 2012 (UTC)

This just happened to me as well. It worked fine downloading a small 4mb update (probably a new launcher) then relaunched with the standard ui. Think they broke somethin' Aro User Aro Signature Logo.gif 22:52, 5 June 2012 (UTC)

I am also having the same issue. Ahaywood 08:16, 27 June 2012 (UTC)

Figured it out. The checkbox for auto-play needs to be checked.

If the -image parameter is used, after the count down ends, instead of launching the game, it will exit. Ahaywood 08:19, 27 June 2012 (UTC)

Just tried using this on the notion of pulling any patch content locally that might be streamed normally. All it does is close the launcher seconds after login or auto. I think this one has been rendered inactive. Azure Fang (talk) 02:51, 2 October 2013 (UTC)

-useoldlauncher[edit]

according to a guru2 post -useoldlauncher will use the old launcher and take you to the old login screen instead of the new merged one. Not sure how they found this out or how long it will be around.

We already know it works. It will probably be around for a while. After all, why would they put the effort into making the old login screen and corresponding command line, to only to nuke them. Waste of time and work. Plus if they fully remove it, there will be crap (as there already is). He found out here: [1] Previously Unsigned 18:29, 14 July 2012 (UTC)

Two unknowns[edit]

I can confirm that -usenewlauncher used the new launcher, even when the old GW1-style launcher was default. Seems useless now, though. As for -nopatch, it does force the game to not update. If used with -useoldlauncher, the update UI will show for a second but act as if there are none; It simply freezes the new launcher (It says checking for updates, but never finishes). And if you stop an update half-way, then run with this, you can expect a nice game crash. —Cat Slayer Calli User Cat Slayer Calli signature.png 20:11, 14 July 2012 (UTC)

E-Mail and Password[edit]

It seems the -email and -password command lines do not work anymore with the new launcher. Can anyone confirm that? --02:02, 19 July 2012 (UTC)

These two arguments do work for me as of right now. — Burfo User Burfo avatar.jpg 05:49, 24 August 2012 (UTC)
These parameters do work - Sortof, never edited a wiki so dont want to change the actual content but here goes details: -email does nothing on its own, -email -password do nothing on their own. -email -password -nopatchui will log you in and open guildwars immediately. (tested on a computer WITHOUT password saved, email address WAS saved - but since -email -password do NOTHING on their own ...)
What does this mean?
You cant share a semi-public computer. IE you cant use -email to fill the "username" field (to subsequently require you to type in the password).
Also tested:
-email -nopatchui, yields a blank black screen (game never 'loads'). (no errors as far as I can tell)
-email -password, yields launcher screen with whatever username was remembered already. (ignores email)
Basically, -email and -password appear to only operate on the *actual game executable* (I suspect this is packed into the patcher executable, or possibly even gw2.dat) What we need is the *patchers* command line arguments. What we have is the actual game executable command line arguments (these get passed through on launch, -nopatchui instantly launches the 'game' executable -- MeateaW 203.17.236.101 21:17, 22 January 2013 (UTC)
GAHHH!!! TWO YEARS I've been trying to figure this out! If you have a space in your password the password has to be enclosed in quote marks!!! I have updated the main page on this. BladeDVD (talk) 20:11, 19 April 2014 (UTC)

Is there any way to auto login with two account's using these command line arguments, I can not get it working, It only remembers the account that was last typed into the login GUI? T1Cybernetic User T1Cybernetic Glob of Ectoplasm.png 19:38, 14 December 2015 (UTC)

-cuda[edit]

I can't confirm it, but I guess the -cuda parameter is for nVidias CUDA Technology. I guess it will then process several things on the GPU instead of the Processor. But as I said, can't confirm that at this point

--Mihawk90 17:55, 6 August 2012 (UTC)

I have a CUDA compatible graphic card, but only one. I've added that argument to test it but dont see a difference. When i run BOINC some projects use CUDA to run faster but i can't run a game at the same time, even displaying Firefox window become slower. Might need an official word about this, maybe i should ask on Twitter, but they already have so much to do. What i think is maybe GW2 wont be able to use CUDA unless there is another capatible graphic card and not in SLI. TulipVorlax 20:15, 2 November 2012 (UTC)
The -cuda arg works when running gw2 with -cuda I get 'LoadLibrary "nvcuda.dll" failed!' as I don't installed it in my Wine Prefix.
Thaodan (talk) 02:16, 11 May 2013 (UTC)

-uninstall[edit]

Tested *without* additional subfolders or extraneous files copied from other locations on the computer. Deletes files (except main executable). Nothing happened the first time I tried this parameter. Second run presented the uninstall dialog.

Should the description of this parameter be moved from the "Unknown commands" section to the main list, or should it remain in the "Unknown commands" list? LarsV 10:34, 23 August 2012 (UTC)

Go ahead and move it out of unknown if you've figured out what it does and have added that information. — Burfo User Burfo avatar.jpg 05:47, 24 August 2012 (UTC)

Tested today with additional text file in the installation folder and additional folder with a sample text file. Confirmed that the additional folder and its contents were intact. The game presented the uninstallatioin dialog on first try. Moved entry out of the list of nonfunctional / unknown effect category. LarsV (talk) 00:32, 17 August 2013 (UTC)

Changes since release[edit]

most arguments don't work any more since release, esp. -perf, -autologin, -nosound, -email, -password. Is this documented somewhere? --The preceding unsigned comment was added by 109.47.247.81 (talk).

I confirm that info Remlwc 10:57, 5 September 2012 (UTC)

I am using -email -password -nopatchui to enable Mumble overlay and not having any problems.

-lang <string> and -defaultLang <string>[edit]

Does anybody know what to use as <string> here? 217.237.93.167 19:17, 20 September 2012 (UTC)

Try the language's ISO code. For example, English is en; French is fr; German is de; Filipino is fil; and so on. Usually today, language strings follow the ISO format. If that doesn't work, then try to using caps EN/FR/DE/FIL/…. If it still failed then go by full name, if that still didn't work then it probably doesn't work or they're using 1,2,3,4,5 as strings. 1 probably is en; 2 probably is de; 3 italia?; 4 probably es (based on the launcher order). --- Laibcoms (talk | Contribs) 00:09, 7 November 2012 (UTC)

-umbra gpu[edit]

Do we have any proof that this line has an effect? I've tested it on my machine and noticed zero change in FPS, GPU usage and CPU usage. --The preceding unsigned comment was added by 24.212.201.168 (talk).

I just tried it out and noticed a slight decrease in both GPU usage (~10%) and frame rate (~10fps). --RoyHarmon (talk) 00:04, 15 May 2014 (UTC)

Multiple Users One computer (With patching!)[edit]

This isn't command-line switches; so I dont know where to put this. (but this functionality is the kind of thing people like to obtain *using* command line arguments to get there, so this is in the Talk page; as a link.

The -Email and -Password switches ONLY work in conjunction with -nopatchui. Which means (1 or more of the following):

1) you must have your password stored in plain text
2) You cannot "remember" an email address only for a specific icon (using just command line arguments)
3) You cannot patch the game if you use the remembered-username-password icon.

There is a solution to every one of these problems. (not as nice and simple as command line switches) The following file is the key: Windows XP: %USERPROFILE%\My Documents\Guild Wars 2\Local.dat Windows 7+ (maybe vista?) %USERPROFILE%\Documents\Guild Wars 2\Local.dat

The Local.dat stores the "remembered" email address, the "remembered" password, and the "auto play" switch.

So, if you share a box with someone you don't trust; you can keep a copy of your local.dat with ONLY remember username ticked, so you have to type in your password. If you share a box with someone you DO trust, you can keep a copy of your local.dat with BOTH username AND password "remembered" And the best part; is no one loses access to the patcher.

On the computer I share with another I have created a "bat" file (Dos scripting for those that don't know it) that performs all of the necesary file-copys; so that all changes I make to my "remember" tick boxes is retained seperately for each "Icon" that you launch Guildwars with.

My file looks something like this:

copy /Y "C:\Users\[Username]\Documents\Guild Wars 2\local_User1.dat" "C:\Users\[Username]\Documents\Guild Wars 2\local.dat" "D:\Games\Guild Wars 2\Gw2.exe" copy /Y "C:\Users\[Username]\Documents\Guild Wars 2\local.dat" "C:\Users\[Username]\Documents\Guild Wars 2\local_User1.dat"

And the other user has a bat file like this:

copy /Y "C:\Users\[Username]\Documents\Guild Wars 2\local_User2.dat" "C:\Users\[Username]\Documents\Guild Wars 2\local.dat" "D:\Games\Guild Wars 2\Gw2.exe" copy /Y "C:\Users\[Username]\Documents\Guild Wars 2\local.dat" "C:\Users\[Username]\Documents\Guild Wars 2\local_User2.dat"

The second "Copy" command ensures that any changes you make to the launcher (Dont want to auto lauch? Don't want to remember password anymore?) is remembered.

Caveats and problems: 2) If you "Remember Password" it is only *slightly* more secure. Now the file is saved in the DAT file, it is harder than right-click properties on an icon, but DONT RELY ON IT. if you DONT TRUST THE COMPUTER (or the other users) DO NOT TICK REMEMBER THE PASSWORD. (hell if you are *actually* worried; DONT USE THE SAME COMPUTER - they can install keyloggers and get access to your password that way too if they have access to the computer)

1) It leaves an ugly Dos-box open while you play; and it only goes away after you quit the game.

For people that just want to remember different Email addresses in the patcher? this is a 100% solution.

HTH -- MeateaW 203.17.236.101 21:43, 7 February 2013 (UTC)

Based on your approach, I created a streamlined method that eliminates the command prompt window:
  • Log into Account 1 and set options as desired. Close Guild Wars 2.
  • Make a copy of local.dat in the same folder. Rename the copy to account1.dat.
  • Log into Account 2 and set options as desired. Close Guild Wars 2.
  • Don't make a copy this time. Leave local.dat untouched.
  • Create a batch file named account1.bat in the same folder as local.dat:
@echo off
if exist "account1.dat" (
rename "local.dat" "account2.dat"
rename "account1.dat" "local.dat" )
start "" "C:\Program Files (x86)\Guild Wars 2\Gw2.exe"
  • Create a batch file named account2.bat in the same folder as local.dat:
@echo off
if exist "account2.dat" (
rename "local.dat" "account1.dat"
rename "account2.dat" "local.dat" )
start "" "C:\Program Files (x86)\Guild Wars 2\Gw2.exe"
  • Create shortcuts to the batch files.
In short, the batch files determine which account is currently represented by local.dat and swap them if necessary before launching Guild Wars 2. - Dannywolt 07:31, 25 February 2013 (UTC)


Based off the previous approach for two accounts, I modified it to work with three.
  • Log into Account 1 and set options as desired. Close Guild Wars 2.
  • Make a copy of local.dat in the same folder. Rename the copy to account1.dat.
  • Log into Account 2 and set options as desired. Close Guild Wars 2.
  • Make a copy of local.dat in the same folder. Rename the copy to account2.dat.
  • Log into Account 3 and set options as desired. Close Guild Wars 2.
  • Don't make a copy this time. Leave local.dat untouched.
  • Create a batch file named account1.bat in the same folder as local.dat:
@echo off
IF EXIST "account1.dat" (
IF EXIST "account2.dat" (
rename "local.dat" "account3.dat"
rename "account1.dat" "local.dat"
)
)
IF EXIST "account1.dat" (
IF EXIST "account3.dat" (
rename "local.dat" "account2.dat"
rename "account1.dat" "local.dat"
)
)
start "" "C:\Program Files (x86)\Guild Wars 2\Gw2.exe"

  • Create a batch file named account2.bat in the same folder as local.dat:
@echo off
IF EXIST "account2.dat" (
IF EXIST "account1.dat" (
rename "local.dat" "account3.dat"
rename "account2.dat" "local.dat"
)
)
IF EXIST "account2.dat" (
IF EXIST "account3.dat" (
rename "local.dat" "account1.dat"
rename "account2.dat" "local.dat"
)
)
start "" "C:\Program Files (x86)\Guild Wars 2\Gw2.exe"

  • Create a batch file named account3.bat in the same folder as local.dat:
@echo off
IF EXIST "account3.dat" (
IF EXIST "account1.dat" (
rename "local.dat" "account2.dat"
rename "account3.dat" "local.dat"
)
)
IF EXIST "account3.dat" (
IF EXIST "account2.dat" (
rename "local.dat" "account1.dat"
rename "account3.dat" "local.dat"
)
)
start "" "C:\Program Files (x86)\Guild Wars 2\Gw2.exe"

This can be expanded with more accounts by adding more If Exist commands and another subset to swap the proper local.dat if necessary. Gedekran 18:23, 04 Janurary 2014 (UTC)
To anyone trying this and not finding Local.dat in the directories specified, please note that it may be here instead: "C:\Users\[username]\AppData\Roaming\Guild Wars 2". --106.68.141.4 11:02, 3 December 2014 (UTC)

-dat[edit]

Verified Used: "D:\games\Guild Wars 2\Gw2.exe" -dat "d:\games\Guild wars 2\Test.dat" It began patching the game; and inflating the size of "Test.dat" Perhaps fully specified path is required. (note the double quotes around the path with a space in it)

Also tried:

Rename gw2.dat -> gw2_different.dat
Launch gw2.exe 
 It began patching (created gw2.dat)
Close patcher
Launch gw2.exe -dat "d:\games\Guild Wars 2\gw2_different.dat"
 It showed fully patched game. (gw2.dat was still incomplete - I didn't want to patch the whole thing)

-- MeateaW 203.17.236.101 22:04, 7 February 2013 (UTC)

-allowinstall[edit]

The -allowinstall switch is incorrectly listed as non-functional.

I recently reinstalled my operating system, wiping my programs and settings in the process. I did make a back-up of gw2.exe and gw2.dat, but my shortcuts were lost in cyberspace. Executing gw2.exe -allowinstall gave me a big red Install button. Upon clicking the button, the client restored my start menu/desktop shortcuts before taking me to the log-in screen. 94.227.1.154 17:50, 6 October 2013 (UTC)

-nopatchui[edit]

It seems that running -nopatchui causes the trading post to bug out. It no longer says "post successful" when posting items, and using the trading post history causes "Login server cannot be accessed." Running the game without it causes no errors. Happens on two accounts I've tried. Looking for confirmation that the -nopatchui command breaks the trading post. --Xdeadzx (talk) 16:50, 19 December 2013 (UTC)


Can confirm, sadly. --Anonymous

-prefreset[edit]

Page showed "Verification requested". ArenaNet Forum Technical Support 'Ashley Segovia' mentions its use to reset preferences in this and many other Official GW2 Forum Tech Support threads: https://forum-en.gw2archive.eu/forum/support/tech/Cannot-load-into-Gendarren-Fields/3753352

50.54.70.187 01:16, 18 May 2014 (UTC)

Does it work together with "GW2 combat mode"?[edit]

...how can I route the ICM.exe via my GW2 shortcut with command line arguments? Titus The Third User titus the third.png 16:37, 27 August 2014 (UTC)

That smells like an unsupported, third-party app - I'm not totally sure if the official wiki is the best place to discuss it. Immersive combat mode? — snogratUser Snograt signature.png 17:45, 27 August 2014 (UTC)
Yupp, that's the one. Though it is an unsupported third-party app indeed, I can't see why it shouldn't be discussed here. It's not in violation with ANets "rules". Titus The Third User titus the third.png 22:37, 27 August 2014 (UTC)
The official wiki is the perfect place to discuss it! We just won't be promoting or condemning its usage by players. ICM.exe would have to let you give it command line arguments when it launches launches gw2.exe. I don't see the feature on the site page.--Relyk ~ talk < 23:21, 27 August 2014 (UTC)
Heh, just being over-cautious. I remember Kerstein giving me a right telling off for linking gwx2 in an IRC chat I was helping to moderate once :) — snogratUser Snograt signature.png 23:29, 27 August 2014 (UTC)
This just in; ArenaNet now seems to hand out temporary suspensions for ICM.The preceding unsigned comment was added by Cronos (talkcontribs) at 21:41, 19 May 2016 (UTC).
Do you have any source for this; out of all the 3rd party programs this seems like one of the least likely to 'bother' Anet. -Darqam (talk) 21:52, 19 May 2016 (UTC)

-autologin has stopped working?[edit]

This stopped working for me recently. Anybody else? -- Crazy Old Man (grumbles) 07:48, 13 September 2014 (UTC)


-assetrserv should be working[edit]

See https://forum-en.gw2archive.eu/forum/support/support/SELFSOLVED-problem-with-1-2-files-remaining/first#post4703909 Irkm Desmet (talk)

usenewbrowser[edit]

Can it be this was functional during the time when ArenaNet switched from Awesomium to Coherent (s. Trading Post#Trivia)? E.g., switching to the then "new" Coherent browser engine to display the Trading Post? Just a guess. - Ray Koopa (talk) 15:04, 27 March 2016 (UTC)

-64?[edit]

Is there such a command as -64, and if so, does it work in the same light as -32, where it forces the client to run in 64-bit mode? -- My Talk Lacky 13:28, 18 May 2016 (UTC)

How is that thing compiled anyway? I don't think so. If the executable could support 64-bit, it would have to be compiled as x64, and then it would stop working on x86 systems, no matter if it uses a -64 flag or not. Ray Koopa (talk) 13:47, 18 May 2016 (UTC)
The 32-bit launcher downloads and runs the 64-bit launcher. (I had an issue where I already had a copy of the 64-bit launcher, but it was broken somehow and crashed on startup. Fixed by deleting it and letting the launcher redownload it. Apparently they don't bother updating the .exe if it already exists...)
I'm not sure if there's a flag to force trying the 64-bit launcher. You should be able to just download and run it manually though (...if it's still available as a separate download). -- Dagger (talk) 13:52, 18 May 2016 (UTC)
Yes, I have now updated my launcher client and it has downloaded the 64-bit version, but I notice the game updates say "the 32-bit client will now automatically switch to the 64-bit client if the conditions appear favorable." I was wondering if this would force it to play in 64-bit mode everytime, rather than just when the conditions are "favourable" (whatever does that even mean? (assuming it just means if you have the capability to do so then it will)). I have added the command line argument to my shortcut, as well as pointing the shortcut to the 64-bit client .exe, but I am not sure how to test whether or not it will now always run in 64-bit or not, or, as per the updates, when the "conditions are favourable". -- My Talk Lacky 14:00, 18 May 2016 (UTC)
Yeah, I have no idea what that means either (64-bit OS + enough RAM?). If you run the 64-bit launcher directly then I'd expect it to always be 64-bit though. -- Dagger (talk) 19:49, 18 May 2016 (UTC)

-email and -password not working any more?[edit]

I haven't used my alts for a while, but the shortcuts were working before, they were in the form of -email XXX -password YYY -nopatchui -autologin (although not sure if the last one is necessary). I tried removing autologin and putting email/pw into "'s, still no dice. Just leaving -email and -pw results in the login ui having my main account's email and pw. Can anyone confirm? (the not working part) Sutgon (talk) 21:44, 28 July 2016 (UTC)

-log[edit]

I often see paths specified as C:\Users\<username>\AppData... all over the internet, but this has several disadvantages:

  • AppData is hidden and most won't see and not find it, thinking it doesn't exist.
  • It cannot be copy-pasted into the Run or address box because of different user names.
  • The path might not be in C:\Users at all.

The correct path would be using environment variables, and in the case of the roaming AppData folder, it's %APPDATA%\Guild Wars2. Pasting that path in the Explorer or Run address box will open the folder correctly every time.

Should I change the wiki text accordingly? - Ray Koopa (talk) 08:36, 3 August 2016 (UTC)

Yes. Also, it's %APPDATA%\Guild Wars 2 (missing space) --BryghtShadow (talk) 10:18, 3 August 2016 (UTC)
That's right. It was me whom added it, I was aware about the nature of AppData folder (hidden and stuff) but at that time I couldn't recall a better way to point it out. I went ahead and changed it to include using environment variables and I think it would be a good info to keep the real path just in case some savvy user would want to know it straightly. Feel free to change it if the text isn't clear or something. --Txon Atana - (talk) 16:13, 3 August 2016 (UTC)
Again I changed it and tried to give a better formating, added a list in case someone would find out what is the path on Mac, per example. Also I put %APPDATA% as the definition and added a note to tell about the real path. --Txon Atana - (talk) 16:35, 3 August 2016 (UTC)

-copydat[edit]

It did not create a new dat file. Moving to deprecated section. --BryghtShadow (talk) 00:32, 16 April 2017 (UTC)

About the forwardrenderer section[edit]

Hi everyone,

We noticed, while we were investigating player reports about lighting bugs, that this section of the article has what we believe to be inaccurate information:

  • In the first bullet point, the part that says "while this is in-use due to the forward renderer being unfinished" is not correct
  • In the second bullet point, it seems that the "is known" and "notably AMD" is player-experience rather than authoritative knowledge; we believe that the statement should be along the following lines: "This may improve overall framerate for certain graphics cards"

Could anyone check the suggested edits above? I can go ahead and make them myself, unless someone wants to, if everyone agrees. Thanks --Stephane Lo Presti talk 19:26, 23 May 2017 (UTC)

No tech knowledge here, but it looks like those two bullets were added by anonymous contributors, with the first dating back to September 2013 and the second in 2015. They were later expanded upon by other people we'll have trouble following up with :(. G R E E N E R 19:52, 23 May 2017 (UTC)

-autologin doesn't work[edit]

Since the recent update the -autologin command no longer works. I know it is just a convinient solution not clicking a button, but I hope it will be fixed. 82.131.207.149 11:33, 9 August 2017 (UTC)

If you are attempting to contact arenanet about this, I highly recommend you go on the official forums, as they will not be looking at a discussion page on the wiki. That said it might be worth putting a bug notice on the page here, although I'm hoping it will be resolved quickly. -Darqam 15:15, 9 August 2017 (UTC)
This was already adressed on reddit and even got a developer reply. No fix in most recent hot fixes tough.

Redirect[edit]

Please add a redirect for 'repair' and possible '-repair', maybe 'repair the client'. It would be helpful when advising players on the forum. Thanks. Inculpatus cedo (talk) 05:06, 24 July 2018 (UTC)