Vulnerable

From Guild Wars 2 Wiki
Jump to: navigation, search
Disambig icon.png This article is about an effect. For the condition with a similar name, see Vulnerability.
.
Vulnerable.png

Vulnerable

Effect type
Effect
Stacking
No
Game link

...

— In-game description

Vulnerable is an effect seen on particularly resilient Mordrem when their Defiance Bar is depleted.

Seen on[edit]

Notes[edit]

  • Greatly increases the damage suffered, considerably more than the similar Exposed effect seen on other enemies with Defiance Bars.